Home > Gentoo Error > Gentoo Error While Loading Shared Libraries Libpng12.so.0

Gentoo Error While Loading Shared Libraries Libpng12.so.0

Although, rather than emerging that specific version, I found it when I stumbled libpng.org. I have 64-bit hardware but the system is 32-bit. Note that registered members see fewer ads, and ContentLink is completely disabled once you log in. whydoesitburn level0 Posts: 2Joined: Wed Oct 24, 2012 6:19 pm Top Re: Multiwinia crashes without starting by bert_the_turtle » Thu Oct 25, 2012 3:33 pm whydoesitburn wrote:Code: Select all/opt/Multiwinia/multiwinia.bin.x86: error http://xhpcreations.com/gentoo-error/gentoo-error-while-loading-shared-libraries-libexpat-so-0.html

For more advanced trainees it can be a desktop reference, and a collection of the base knowledge needed to proceed with system and network administration. Tango Icons Tango Desktop Project. Last edited by theClassicMan27 (2012-07-07 16:31:42) Offline #2 2012-07-07 11:50:12 Gcool Member Registered: 2011-08-16 Posts: 1,456 Re: [SOLVED] Error while loading shared libraries: libSM.so.6 Does /usr/lib/libSM.so.6 exist on your system (according However I believe the above quote is not the best way to get help. navigate to these guys

Click Here to receive this Complete Guide absolutely free. LD_LIBRARY_PATH=/home/jserink/Bricscad/ bricscadQuote #11 2011-05-19 07:02 john serinkHi Mattias: I use the startup script for it: [email protected] ~/Bricscad $ cat bricscad.sh #!/bin/sh export LD_LIBRARY_PATH=`pwd` exec ./bricscad "[email protected]"

Which is i92guboj View Public Profile View LQ Blog View Review Entries View HCL Entries Visit i92guboj's homepage! You can indeed check with ldd, but just like when running bricscad, LD_LIBRARY_PATH needs to be set first: LD_LIBRARY_PATH=/home/jserink/Bricscad/ ldd -r /home/jserink/Bricscad/bricscad posts that might be helpful: GLX

Use find or whatever tool you prefer to locate all the libpng versions in your system. Exploded Suffixes How exactly does the typical shell "fork bomb" calls itself twice? You are currently viewing LQ as a guest. How can I get it to spit out more information when it segfaults so I can trouble shoot this?

Last, but not least, even if emacs truly needs libpng-1.2 (and I really doubt it, but I am not going to bother installing emacs just to check), you could just do Join Date Oct 2009 BeansHidden! We have cookies! | Basic Ubuntu Security Guide Tomorrow's an illusion and yesterday's a dream, today is a solution... Having a problem logging in?

Have you done these? Burninate! The files are named using the scheme [0-9][0-9]somename - the two initial digits decide on the order in which they are used. Cheers, John

Quote #16 2011-06-30 14:42 john serinkHi Guys: i couldn't get googleearth to work on my Gentoo install and the problems are similar to Bricsys....googleearth runs using 32 bits

jserinkturion Bricscad # export LD_LIBRARY_PATH=`pwd` jserinkturion Bricscad # ldd -r /home/jserink/Bricscad/bricscad linux-gate.so.1 => (0xffffe000) libutils.so => /home/jserink/Bricscad/libutils.so (0xf76b0000) libdcl.so => /home/jserink/Bricscad/libdcl.so (0xf7616000) libgeometry.so => /home/jserink/Bricscad/libgeometry.so (0xf760b000) libodapp.so => /home/jserink/Bricscad/libodapp.so (0xf7376000) libcadapp.so https://ubuntuforums.org/showthread.php?t=2149728 Ubuntu got me started with linux. Burninate! So all load-time dependencies are satisfied.

Cheesemill Adv Reply May 30th, 2013 #7 CharlesA View Profile View Forum Posts Private Message Visit Homepage Beware of Hat... check over here Blackened Justice Linux - Newbie 4 09-08-2011 07:57 AM Error while loading shared library : libpng12.so.0 dhanilshah Linux - Software 5 08-18-2011 07:38 AM /usr/lib/libpng12.so.0 no version information available H_TeXMeX_H Slackware When will bricscad be releasing a 64bit binary? I have an Intel Atom D510 motherboard running under Ubuntu 11.04 with 2 GB of ram and a 1920x1200 lcd screen.

The app is said to get built fine. –rozcietrzewiacz Nov 24 '11 at 19:25 add a comment| up vote -1 down vote You have to tell your system where to look Come to #ubuntuforums! Burninate! http://xhpcreations.com/gentoo-error/gentoo-error-while-loading-shared-libraries-libssl-so.html Hot Network Questions How can I make LaTeX break the word at the end of line more beautiful?

Cheers, johnQuote #9 2011-05-19 03:46 john serinkOk have a look at this: jserinkturion Bricscad # locate -i libDD_Alloc.so /home/jserink/Bricscad/libDD_Alloc.so jserinkturion Bricscad # locate -i libDD_Root.so /home/jserink/Bricscad/libDD_Root.so jserinkturion Bricscad # locate libDD_Alloc.so And in any case, I really disregard that kind of practice, because it can cause issues like the one you are experiencing right now and some darker ones. Modulo % with big number- Infinity error - Javascript In a long sum, how can we find how many terms are preceded by the plus (or minus) sign When to use

Your tip makes sense and looking at the script bricscad.sh it follows: [email protected] ~/Bricscad $ cat bricscad.sh #!/bin/sh export LD_LIBRARY_PATH=`pwd` exec ./bricscad "[email protected]" But, it puts me back to square 1.

Is it plausible for my creature to have similar IQ as humans? Reading symbols from /home/jserink/Bricscad/bricscad...done. (gdb) run Starting program: /home/jserink/Bricscad/bricscad warning: the debug information found in "/home/jserink/Bricscad/libjpeg.so.62.0.0" does not match "/home/jserink/Bricscad/libjpeg.so.62" (CRC mismatch). http://www.webupd8.org/2012/01/tool-...b-install.html http://pastebin.com/vpuYyhrt here's the error when i try that Adv Reply May 29th, 2013 #4 archlinuxisbetter View Profile View Forum Posts Private Message First Cup of Ubuntu Join Date May I guess I am saying it would be beneficial to just stick to your issues and having them fixed.

Ubuntu Logo, Ubuntu and Canonical Canonical Ltd. It should probably be under /usr/bin/emacs, so try running it with the fully qualified path just to be sure. It's curious, though, that emacs still depends on an old library... weblink CollieJim View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by CollieJim Thread Tools Show Printable Version Email this Page Search this Thread Advanced

Do you more expierned people come to the same conclusion? share|improve this answer answered Nov 24 '11 at 19:18 amphetamachine 2,99711533 If that were the issue, wouldn't ld complain during building? Offline #11 2012-07-07 16:32:42 theClassicMan27 Member From: /home/ty Registered: 2012-06-26 Posts: 14 Website Re: [SOLVED] Error while loading shared libraries: libSM.so.6 Gcool wrote:Good to hear it's up and running now.Don't forget I still have ubuntu installed on my multiboot system.

Just to recap, the program starts, informs me via a dialog box that I have 26 days left I click the "continue" button, Bricscad starts, the main screen pops up, paints Checking your browser before accessing teamspeak.com. Reason: spelling Multi-boot: Arch linux, Ubuntu 12.04, Windows 7 & Windows 8 Adv Reply Quick Navigation Installation & Upgrades Top Site Areas Settings Private Messages Subscriptions Who's Online Search Forums Search this Thread 01-08-2012, 05:40 AM #1 CollieJim Member Registered: Mar 2005 Distribution: Gentoo, Kubuntu Posts: 507 Rep: Why does emacs-23.3-r2 still need libpng12.so.0?

No one likes to be told anything bad about something they like. Code: $ emacs emacs: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory Why does emacs still need libpng12? Contact Us - Advertising Info - Rules - LQ Merchandise - Donations - Contributing Member - LQ Sitemap - Main Menu Linux Forum Android Forum Chrome OS Forum Search LQ Results 1 to 8 of 8 Thread: how do i install unetbootin 494 Thread Tools Show Printable Version Subscribe to this Thread… Display Linear Mode Switch to Hybrid Mode Switch to

Anyway, on Gentoo I had to downgrade on my pre-compiled 32 libraries to 2010 versions from the brand spanking new 2011 versions to get googleearth to run which I have now When I use the script brisccas.sh to start the program it finds that library due to the second line in the script above....but then I get a seg fault. share|improve this answer edited Nov 24 '11 at 21:19 answered Nov 23 '11 at 20:32 rozcietrzewiacz 22.2k15079 add a comment| Did you find this question interesting? There was an old copy in /usr/local/bin.

What would be the atomic no. Offline #3 2012-07-07 12:26:00 theClassicMan27 Member From: /home/ty Registered: 2012-06-26 Posts: 14 Website Re: [SOLVED] Error while loading shared libraries: libSM.so.6 Thanks for your reply Gcool,Unluckily, there's libSM.so.6 already exist.[[email protected] ~]$ I compile the software by doing the following steps: $ cd lib/3rdpartylib/ $ make $ ln -s 3rdpartylib.so.0 3rdpartylib.so Then I compile each of my source files like this: $ gcc Or you link using a 'static' library search paths like this: gcc file1.o file2.o -L./lib/3rdpartylib -Wl,-rpath=./lib/3rdpartylib -l3rdpartylib -o myapp -Wl specifies commmand line arguments that will not be processed by gcc

I have tried linking libpng12.so.0 to other versions, but emacs (or something it calls) checks for an identification string in the library and rejects the link.