Home > Gentoo Error > Gentoo Error While Loading Shared Libraries Libgl.so.1

Gentoo Error While Loading Shared Libraries Libgl.so.1

In an attempt to find the issue, I tried running these programs from the command line, and they all yield the same error message: Code: glxinfo: error while loading shared libraries: Hot Network Questions Implementation of a generic List What sense of "hack" is involved in "five hacks for using coffee filters"? Good luck! It may need removing before running eselect if it is a dead link or a real file. his comment is here

The problem is that Ubuntu can't find the file libGL.so because it either hasn't been installed, or - more likely - its someplace unexpected. (In my case, it turned up in Best debugging is to look in ~/Lightworks/Logs/... How should I interpret "English is poor" review when I used a language check service before submission? I am running Xubuntu Hardy. https://forums.gentoo.org/viewtopic-t-449210-start-0.html

regards Fred Kastl ### ldd: .. Sign in to comment Contact GitHub API Training Shop Blog About © 2016 GitHub, Inc. What am I missing?

Please visit this page to clear all LQ-related cookies. But I understand that using LD_LIBRARY_PATH is a bad practice. nvidia 12.10 64-bit shared-library steam share|improve this question asked Nov 12 '12 at 20:37 Olcay Ertaş 42531435 I can confirm, that reinstalling the libgl1 library did help. Ubuntu 14.04 x86-64, desktop compiz, graphical driver Nvidia for GEForce GTS 450. –hariprasad Jul 10 '14 at 8:46 add a comment| 8 Answers 8 active oldest votes up vote 11 down

My own install is correctly linked. Doing so yields three packages- non of which can be installed without removing several other important looking packages, one of which being "xubuntu-desktop" which I definitely do not want to get warnings.warn('Specified path %s is invalid.' % d) libraries not found in ['/usr/lib64'] NOT AVAILABLE /usr/lib64/python2.7/site-packages/numpy/distutils/system_info.py:1521: UserWarning: Blas (http://www.netlib.org/blas/) libraries not found. For instance: "sudo ln -s /usr/lib/libGL.so /usr/lib/directoryname/libGL.so.1.4" This is just a slightly more detailed explanation based on previous posts, but I thought it might make it easier for the next person.

Linux User: 401820 Last FM Offline #14 2014-03-08 13:46:23 t0m5k1 Member From: overthere Registered: 2012-02-10 Posts: 309 Re: nvidia-libgl: /usr/lib/libEGL.so exists in file system clearly you have not read the wiki.this The second part of the command tells your computer what the other file is. Offline #2 2014-03-08 08:37:35 Meirion Member Registered: 2009-10-04 Posts: 26 Re: nvidia-libgl: /usr/lib/libEGL.so exists in file system Hi, When installing latest version of libgl-nvidia I get a conflict.Packages (1): nvidia-libgl-334.21-2Total Installed I just extracted the lib's from a rpm and placed it in /usr/lib/lightworks.

Offline #6 2014-03-08 09:18:01 H3g3m0n Member Registered: 2009-02-01 Posts: 15 Re: nvidia-libgl: /usr/lib/libEGL.so exists in file system I have this problem too. reinstalling nvidia files and mesa changed nothing - and i was unable to remove mesa - it has so many dependeces, withy their dependeces... Whenever I click on these select programs, nothing happens- that is, the program won't start. Is there any job that can't be automated?

The odd thing is that these programs USED to work fine- they just sort of stopped working a few days ago. this content If you'd like to contribute content, let us know. Browse other questions tagged nvidia 12.10 64-bit shared-library steam or ask your own question. I'll follow the bug issue and mark this thread closed when the bug is resolved.

It's very rare for Linux to perform very badly. carldong commented Aug 6, 2014 I have deleted them now. Directories to search for the libraries can be specified in the numpy/distutils/site.cfg file (section [blas]) or by setting the BLAS environment variable. weblink Directories to search for the libraries can be specified in the numpy/distutils/site.cfg file (section [blas]) or by setting the BLAS environment variable.

python2.7 setup.py build -b build-2.7 config_fc --noopt --noarch /usr/lib64/python2.7/distutils/dist.py:267: UserWarning: Unknown distribution option: 'test_suite' warnings.warn(msg) blas_opt_info: blas_mkl_info: libraries mkl,vml,guide not found in ['/usr/local/lib64', '/usr/local/lib', '/usr/lib64', '/usr/lib', '/usr/lib/'] NOT AVAILABLE openblas_info: libraries Registration is quick, simple and absolutely free. nvidia recetly added egl to their drivers and it seems to conflict with Mesa.

So your answer is better ;-) –fab Nov 24 '11 at 20:33 add a comment| Your Answer draft saved draft discarded Sign up or log in Sign up using Google

Reply Quote Menu Re: [SOLVED] Gentoo .ebuild for 12.0 1 year, 8 months ago #88056 wozza OFFLINE Senior Boarder Posts: 47 1 year, 8 months ago #88056 @mcdebugger: Just noticed the Create an account [prev in list] [next in list] [prev in thread] [next in thread] List: gentoo-user Subject: Re: [gentoo-user] nVidia OpenGL on a 64-bit system not recognized by 32-bit apps The problem starts when I don't even edit something and sitting on the start screen, where the project should be created, so no heavy I/o at this stage. If you look at the gcc man page, it states that when specifying a library path with -L it must come before the -l flags, or it will not be searched.

I suspect you have recently updated the package providing libGL.so (it could be mesa or your graphics card drivers), in which case, you need to re-emerge mplayer. Is there any way to know when NOT to use my Oyster card? 5008 out of the box Why doesn't ${@:-1} return the last element of [email protected]? Are you new to LinuxQuestions.org? http://xhpcreations.com/gentoo-error/gentoo-error-while-loading-shared-libraries-libssl-so.html ldd spawn linux-vdso.so.1 (0x00007ffff12ae000) libOS.so => /usr/lib64/lightworks/libOS.so (0x00007f14ea4f0000) libmisc.so => /usr/lib64/lightworks/libmisc.so (0x00007f14ea144000) libstdc++.so.6 => /usr/lib/gcc/x86_64-pc-linux-gnu/4.8.3/libstdc++.so.6 (0x00007f14e9e3f000) libgcc_s.so.1 => /usr/lib/gcc/x86_64-pc-linux-gnu/4.8.3/libgcc_s.so.1 (0x00007f14e9c29000) libc.so.6 => /lib64/libc.so.6 (0x00007f14e9883000) libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f14e9665000) libgtk-3.so.0 => /usr/lib64/libgtk-3.so.0

It bothers me to have this variable set up every time I want to run my app. I just hope EditShare is going to change that dependencies sooner or later Reply Quote Menu Reply Topic New Topic Page:12 Lightworks ForumMainInstallation / Drivers / Hardware / OS Board CategoriesAnnouncements...AnnouncementsMain...Installation See here:https://bugs.archlinux.org/task/39219?p … idia-libglBasically, libnvidia-glsi.so.334.21 will be missing and lots of things will break. Attachments: This image is hidden for guests.

share|improve this answer edited Dec 7 '13 at 22:47 minerz029 12.9k84480 answered Feb 23 '13 at 23:05 terrigan 291 Using "Mint" as a basis is not suggested, since Mint Why does it work on my main machine (where LD_LIBRARY_PATH is not set to anything) and not on the other machine? roll back! (In somewhat unrelated news, you can use it on wine prefixes to keep a 'fresh' copy before you go and install everything under the sun via winetricks, very handy) It compiled and linked without any problem.

Gentoo Science Project member kiwifb commented Aug 5, 2014 I'd say something is hard coding libblas and liblapack somewhere, don't know if it is the ebuild or somewhere in octave's gut. All the solutions above (creating symlinks, configuring LD_LIBRARY_PATH) didn't work for me. Offline #4 2014-03-08 09:08:10 Meirion Member Registered: 2009-10-04 Posts: 26 Re: nvidia-libgl: /usr/lib/libEGL.so exists in file system Thanks Frudox. Just a > guess on my part though. > > Hope that helps. > > Dale > > :-) :-) :-) -- gentoo-user [at] gentoo mailing list Index | Next

I installed the glu package. I would inspect umfpack and arpack. current community chat Unix & Linux Unix & Linux Meta your communities Sign up or log in to customize your list. and now after reboot, i get black screen...