Home > Gentoo Error > Gentoo Error Dev-lang/python-2.5.4-r4 Failed

Gentoo Error Dev-lang/python-2.5.4-r4 Failed

Good. Regards, Moritz Replies Subject Author Re: [gentoo-user] Failed to emerge dev-lang/python-2.5.4-r4 Alex Schuster Report Message Find on GMANE Find on MARC All times displayed are in UTC (GMT+0). This version of portage requires at least python-2.6 to be selected as the default python interpreter
Lets try to force python then. Single > will just overwrite it. navigate here

Reverse DNS lookupFind out which hostname(s)resolve to agiven IP or other hostnames for the server www.reversednslookup.org New Packages - as - as - as 2016-10-17 calibre - 2.70.0Ebuild name:app-text/calibre-2.70.0DescriptionEbook management applicationAdded Lets try 2.1.9.42. They are marked in ebuilds for a reason but with some luck we can ignore them and maybe get something semi-working out of it. kernel treeAdded to portage2016-10-17 google-chrome-unstable - 55.0.2883.11Ebuild name:www-client/google-chrome-unstable-55.0.2883.11DescriptionThe web browser from GoogleAdded to portage2016-10-17 jasper - 1.900.5Ebuild name:media-libs/jasper-1.900.5DescriptionImplementation of the codec specified in the JPEG-2000 Part-1 standardAdded to portage2016-10-17 kdelibs -

Please feel free to contact us. © 2001–2016 Gentoo Foundation, Inc. I do use oneshot here as those packages are dependencies of something else anyway and I do not want to add them in my world file. The Gentoo Name and Logo Usage Guidelines apply. [prev in list] [next in list] [prev in thread] [next in thread] List: gentoo-user Subject: Re: [gentoo-user] problem updating python From: Kaddeh be great if someone could tell >> me where to look for debugging infos. > > Look at yout build.log, line 942, a libpython2.5.so.1.0 cannot

Please feel free to contact us. © 2001–2016 Gentoo Foundation, Inc. Quick look around in another, up to date machine reveals that ffi.h is supplied by dev-libs/libffi and actually virtual/libffi was one of the dependencies on python. Bash 4.1_p9 requires portage 2.1.7.6 at minimum. Basically, newer portage is needed.

done!
[ebuild  N    ] dev-libs/libffi-3.0.9-r2  USE="-debug -static-libs -test" 715 kB
[ebuild  N    ] app-misc/mime-types-8  12 kB
[ebuild  N    ] virtual/libffi-0  0 kB
[ebuild  NS   ] dev-lang/python-2.7.1-r1 [2.3.6-r4, I would investigate further, but I don't know how to make portage tell me more about the error that occured! done!
[ebuild  N    ] dev-libs/libffi-3.0.9-r2  USE="-debug -static-libs -test" 715 kB
[ebuild  N    ] app-misc/mime-types-8  12 kB
[ebuild  N    ] virtual/libffi-0  0 kB
[ebuild     U ] app-shells/bash-4.1_p9 [3.2_p39] https://archives.gentoo.org/gentoo-user/message/caab40e8fd54417a7a0eeb89f2abfc76 Sorry, my time is up, Wonko Replies Subject Author [gentoo-user] Re: Failed to emerge dev-lang/python-2.5.4-r4 Moritz Schlarb Report Message Find on GMANE Find on MARC All times displayed are in

I don't know why, and I have no time to look further right now. emerge -avu portage Calculating dependencies... gmail ! gentoo.org sites gentoo.org Wiki Bugs Forums Packages Planet Archives Sources Infra Status Archives Toggle navigation Home All Archives gentoo-user Gentoo Archives: gentoo-user From: Moritz Schlarb To: [email protected] Subject: [gentoo-user] Re:

Installing is not so simple. https://marc.info/?l=gentoo-user&m=127440540314687 If you continue to use the site, you accept the use of cookies.more info jump to the content Gentoo.LinuxHowtos.org howtos, tips&tricks and tutorials for gentoo linux from small one page howto Looking at  /usr/portage/sys-apps/portage/portage-2.1.10.11.ebuild we can find a row declaring: build? ( || ( dev-lang/python:2.7 dev-lang/python:2.6[threads] )
so lets mask python 2.7 echo  ">=dev-lang/python-2.7" >>/etc/portage/package.mask
Please notice the >> this Contents reflect the opinion of the author, not the Gentoo project or the Gentoo Foundation.

done!
[ebuild  N    ] dev-libs/libffi-3.0.9-r2  USE="-debug -static-libs -test" 715 kB
[ebuild  N    ] app-misc/mime-types-8  12 kB
[ebuild  N    ] virtual/libffi-0  0 kB
[ebuild  NS   ] dev-lang/python-2.6.6-r2 [2.3.6-r4, check over here Just a lot of patience. The thing to remember - keep Your systems up to date - it is a lot easier this way. Close This site uses cookies for advertising.

For example portage is 2.1.6.13, bash is 3.2_p39 and python is 2.5.4. Contents reflect the opinion of the author, not the Gentoo project or the Gentoo Foundation. I already wanted to file a bug, so I ran emerge again to get the build logs again, but then emerge ran fine... his comment is here ls /usr/portage/dev-lang/python/ | grep ebuild python-2.4.6.ebuild
python-2.5.4-r4.ebuild
python-2.6.6-r2.ebuild
python-2.6.7-r2.ebuild
python-2.7.1-r1.ebuild
python-2.7.2-r2.ebuild
python-2.7.2-r3.ebuild
python-3.1.3-r1.ebuild
python-3.1.4-r2.ebuild
python-3.1.4-r3.ebuild
python-3.2.2.ebuild
python-3.2-r2.ebuild
Nope.

So here we have the first circular dependency. Questions or comments? If you continue to use this website without changing your cookie settings or you click "Accept" below then you are consenting to this.

Get Gentoo!

But I'm eager to learn, would be great if someone could tell me where to look for debugging infos. gentoo.org sites gentoo.org Wiki Bugs Forums Packages Planet Archives Sources Infra Status Archives Toggle navigation Home All Archives gentoo-user Gentoo Archives: gentoo-user From: Alex Schuster To: [email protected] Subject: Re: [gentoo-user] done!
[ebuild  N    ] dev-libs/libffi-3.0.9-r2  USE="-debug -static-libs -test" 715 kB
[ebuild  N    ] app-misc/mime-types-8  12 kB
[ebuild  N    ] virtual/libffi-0  0 kB
[ebuild  NS   ] dev-lang/python-2.6.6-r2 [2.3.6-r4, echo  ">=app-shells/bash-3.2_p39" > /etc/portage/package.mask
New test on emerge emerge -avu portage These are the packages that would be merged, in order:
Calculating dependencies...

First upgrade, then mask if upgrade does not work, then -nodeps if mask is not enough. I would investigate further, but I > don't know how to make portage tell me more about the error that > occured! Questions or comments? weblink Get Gentoo!

Finding out the minimum version of bash required is simple: cat /usr/portage/sys-apps/portage/portage-2.1.10.11.ebuild | grep bash
>=app-shells/bash-3.2_p17
To break that circle, lets mask newer bash first. kernel treeAdded to portage2016-10-17 gentoo-sources - 4.7.8Ebuild name:sys-kernel/gentoo-sources-4.7.8DescriptionFull sources including the Gentoo patchset for the . Next other development tools, python (it got updated already) , perl, gcc should be upgraded. Back to the beginning then.

echo  ">dev-util/pkgconfig-0.22" >> /etc/portage/package.mask
Trying python again: emerge -avu =dev-lang/python-2.6.6-r2 These are the packages that would be merged, in order:
Calculating dependencies... You are here: Portage Details of virtual/mpi: Description: Virtual for Message Passing Interface (MPI) v2.0 implementation Homepage: available versions: releasesalphaamd64armhppaia64mipsppcppc64ppc macoss390shsparcx86USE-Flagsdependenciesebuild warnings mpi-2.0-r4 ~~~~--~~----~cxxfortranromiothreadsshowshowmpi-2.0-r3 ++-++-++---++cxxfortranromiothreadsshowshowLegend:+ stable~ testing- not availablesome ebuild warning Specially those that do more than -r (revision) version upgrades and that do some uninstalls. But I'm eager to learn, would be great if someone could tell > me where to look for debugging infos.

com [Download message RAW] what is the output of "eselect python list" On Thu, May 20, 2010 at 11:43 AM, Rene Lopez Montelongo < [email protected]> wrote: > Hi everyone > I'm python-updater is a no go, as it needs newer python of course. It depends on python 2.7 or 2.6 and bash at minimum of 3.2_p17, but as newer bash 4.1 is available, emerge -avu wants to upgrade to it. Reply Leave a Reply Cancel reply Name (required) E-mail (required) URI Your Comment You may use these HTML tags and attributes:

rm /etc/portage/package.mask
Now we can install python with dependencies. Get Gentoo! I have had to use that only once fortunately. This tends to happen if nodeps is used on installing packages.

more information Accept The cookie settings on this website are set to "allow cookies" to give you the best browsing experience possible. done!
[ebuild  N    ] dev-libs/libffi-3.0.9-r2  USE="-debug -static-libs -test" 715 kB
[ebuild     U ] dev-libs/expat-2.0.1-r3 [2.0.1] 0 kB
[ebuild     U ] sys-libs/gdbm-1.8.3-r4 [1.8.3-r3] USE="berkdb" 0 kB
[ebuild  N    Is there something older? done!
!!!