Home > Gem Install > Gem Install Zlib

Gem Install Zlib

Contents

I did to a slight shotgun approach to zlib before finding that everything needed was covered by libruby. I always thinking Ubuntu or other Linux package manager systems like Portage is much ore better than what Windows have, but in the case of install Ruby Gems Linux doesn't seems And tada! For details and our forum data attribution, retention and privacy policy, see here UbuntuCommunityAsk!DeveloperDesignDiscourseHardwareInsightsJujuShopMore ›AppsHelpForumLaunchpadMAASCanonical current community chat Ask Ubuntu Ask Ubuntu Meta your communities Sign up or log in to this contact form

I am using Fedora, so I used yum to install rvm, but > can't seem to get that working either. Also as you can see I have zlib[devel] installed. Some one >> mentioned something about the headers being installed with zlib??? Ubuntu Ubuntu Insights Planet Ubuntu Activity Page Please read before SSO login Advanced Search Forum The Ubuntu Forum Community Ubuntu Specialised Support Development & Programming Programming Talk Can't install Ruby on

Gem Install Zlib

Why is water evaporated from the ocean not salty? Stick with 1.8.6, preferably the Ruby Enterprise Edition. Dowload Ruby source code and install it ( Ruby 1.9.1-p376 (md5: ebb20550a11e7f1a2fbd6fdec2a3e0a3) from http://www.ruby- lang.org/en/downloads/ $ ./configure; make; sudo make install Here is the result : Code: [email protected]:/usr/local/bin$ ruby -v ruby So, I actually READ the README and find that I need to edit a file ... [my ruby source directory]/ext/Setup and UN-COMMENT the line with zLib in it ...

Join Date Oct 2004 Location USA Beans 330 DistroUbuntu 16.04 Xenial Xerus Re: Can't install Ruby on Rails Is there a specific reason you are installing ruby and rubygems from source? Otherwise there will be problems, because not all common tools reside in the /usr/bin and one probably wants to have multiple custom-built applications in use. Ask Ubuntu works best with JavaScript enabled Log in / Register Ubunturubygems package Overview Code Bugs Blueprints Translations Answers Ruby gem command install does not find zlib Asked by Tommy Pollák Ruby Zlib Is Missing Necessary For Building Libxml2 How much is "a ladleful"?

Existing account User name or e-mail address Password Always use SSL (experimental!) NEW: Do you have a Google/GoogleMail, Yahoo or Facebook account? Install Ruby Zlib Ubuntu First try it from Synaptic, and with the latest stable versions, but as you wish. If not, you may try to install ruby-zlib. Why is absolute zero unattainable?

I had a similar problem on OS X and updating Compress::Zlib (a Perl interface to ZLib) cured it - so I think an old version of ZLib (is now 1.2.3) may Zlib Ruby Setting up zlib1g-dev (1:1.2.3.4.dfsg-3ubuntu4) ... I could solve my problem! Not being snarky, just saving space.

Install Ruby Zlib Ubuntu

Adv Reply November 9th, 2010 #7 brezenix View Profile View Forum Posts Private Message First Cup of Ubuntu Join Date Jun 2008 Location Moscow, Russia Beans 1 DistroUbuntu 10.10 Maverick here http://www.lucas-nussbaum.net/blog/?p=550 brezenix has the right idea. Gem Install Zlib As of April 2011 I haven't sorted the details of it out, but apt-get install zlibc zlib1g-dev zlib1g seems to be sufficient on a Debian system. Ruby Zlib Is Missing Physically locating the server Relation between representations of p-adic groups and affine Hecke algebras reading through the definition of `\cfrac` in AMSMath What sense of "hack" is involved in "five hacks

more hot questions question feed about us tour help blog chat data legal privacy policy work here advertising info mobile contact us feedback Technology Life / Arts Culture / Recreation Science weblink asked 3 years ago viewed 5405 times active 1 year ago Related 1Installed Ruby 1.9.2 but new gems won't create scripts into /usr/bin0How do I install Capistrano?6“no such file to load Why does argv include the program name? So i thought i'd leave a note on how i managed to finally fix this. Gem Install Cannot Load Such File Zlib

Report post Edit Move Delete topic Reply with quote Re: can't install rails - gem is asking for a zlib Hugo Roque (Guest) on 2010-09-01 22:51 check if exist the file Any ideas of what might be the root problem? If one wrote export PATH="/usr/bin:/home/scoobydoo/ourcompiledruby/bin" to the /home/scoobydoo/.bashrc ,then the /usr/bin/irb would get executed. http://xhpcreations.com/gem-install/gem-install-rails-bus-error.html yum install zlib zlib-devel Second, I recompiled and installed the sources of zlib that comes with ruby.

How to draw a path with coordinates defined by f(x) Is there a Korean word for 'Syllable Block'? Undefined Method `invoke_with_build_args' For Nil:nilclass But in both cases build it yourself or use Marans suggestion. Yes, I have zlib and zlib-devl > installed.

something about zLib not found crap ...

cheers! What happens if one brings more than 10,000 USD with them in the US? After rbenv uninstall 1.9.3-p286 rbenv install 1.9.3-p286 gem install rails worked! Install Rvm Ubuntu Then go back to where you built Ruby, cd to ext/zlib, and run "ruby extconf.rb; make; sudo make install".

I downloaded the most recent version (1.2.3) and installed it there. Why was the identity of the Half-Blood Prince important to the story? See my output below for what I have installed, and the error I get when I try and run any gem commands. http://xhpcreations.com/gem-install/gem-install-rubyinline-error.html share|improve this answer answered Jan 29 '15 at 12:41 IllegalCactus 213 add a comment| Your Answer draft saved draft discarded Sign up or log in Sign up using Google Sign

Regards, Dan Report post Edit Delete Reply with quote Re: Re: Re: can't install rails - gem is asking for a zlib Zoltan Gero (gezope) on 2010-09-02 00:51 Congratulations! gem list it doesn't work ... Why doesn't ${@:-1} return the last element of [email protected]? more stack exchange communities company blog Stack Exchange Inbox Reputation and Badges sign up log in tour help Tour Start here for a quick overview of the site Help Center Detailed

Its a little unsatisfiying through, because I'm not sure exactly what part of that tutorial fixed the gem install. For instance after installing I don't have a /usr/local/rvm folder. What actually are virtual particles? Ubuntu Logo, Ubuntu and Canonical © Canonical Ltd.

Getting help from this post: echo "[[ -s '${HOME}/.rvm/scripts/rvm' ]] && source '${HOME}/.rvm/scripts/rvm'" >> ~/.bashrc echo "[[ -s '${HOME}/.rvm/scripts/rvm' ]] && source '${HOME}/.rvm/scripts/rvm'" >> ~/.zshrc curl -L https://get.rvm.io | bash -s share|improve this answer edited May 2 '11 at 6:06 Yuki Nishijima 1,55221219 answered Apr 21 '09 at 17:15 Paul 15.9k54571 1 I had a problem running extconf.rb. Did you make the changes to .bashrc (or whatever the equivalent in Fedora) as described on the website after installing rvm? Just try again, or download gems manually and point gem at the files.

Tommy Pollák (tpollak) said on 2012-11-10: #5 Yes! included here for reference ... ./configure make install sudo make install and all is well ... I had plenty of problems installing Rails on Ubuntu, so if you still cannot install it well, please let me know, or also you can find me in private. I've even found a few tutorials on this particular problem (all for flavors other than mine, however) but they didn't help.