Home > Gem Install > Gem Install Webrat Error

Gem Install Webrat Error

for testing AJAX interactions) Supports multiple Ruby web frameworks: Rails, Merb and Sinatra Supports popular test frameworks: RSpec, Cucumber, Test::Unit and Shoulda Webrat::Matchers API for verifying rendered HTML using CSS, XPath, Can cats leave scratch marks on cars? elia commented Aug 31, 2010 I had the same issue, resolved just now removing an half installed gem which probably failed compilation in the past. ERROR: Error installing webrat: Could not create Makefile due to some reason, probably lack of necessary libraries and/or headers. navigate here

Its really pissing me off. Unsubstantiated Is there any job that can't be automated? lib Split to 2 strings for base64 encoded value Feb 20, 2013 spec Bug fix for finding a field by name using a regex Oct 30, 2012 vendor Bump vendored Selenium I started on Windows platform but I was getting many errors so switched to Linux Mint Release 12 (lisa), Kernel Linux 3.0.0-12-generic, GNOME 3.2.1.

Browse other questions tagged ruby webrat or ask your own question. OP used update_rubygems. Problem solved. –Thomas Johan Eggum Mar 5 '12 at 10:05 I will move it to an an answer then! –ScottJShea Mar 5 '12 at 13:28 add a comment| 1 graysonwright added a commit that referenced this issue Nov 21, 2015 graysonwright I missed that. (= johncblandii commented Nov 11, 2015 No prob. :) graysonwright added this to the v0.1.2 milestone Nov 12, 2015 graysonwright added the ready label Nov 12, 2015 johncblandii

asked 6 years ago viewed 1446 times active 5 years ago Get the weekly newsletter! No definition for parse_memory No definition for parse_file No definition for parse_with No definition for get_options No definition for set_options Installing ri documentation for rack-test-0.5.3... I am wondering these might be the root of cause. johncblandii commented Jan 21, 2016 Really late, but I tried this again yesterday and it worked.

If you like, point your Gemfile to the master branch on github and try the installers from there. If that step is needed, I wouldn't mind. You signed out in another tab or window. I removed it, and now it works.

You may have looked over it in the above output but the third library file that the nokogiri gem depends on is where the failure is located. http://xhpcreations.com/gem-install/gem-install-sproutcore-error.html Can a GM prohibit a player from referencing spells in the handbook during combat? You signed out in another tab or window. Report post Edit Delete Reply with quote Re: newbie: errors getting started with cucumber Aslak Hellesøy (aslakhellesoy) on 2008-12-25 20:01 On Thu, Dec 25, 2008 at 2:04 PM, Manasi Vora

Run bundle install to install missing gems. techmistry commented Mar 12, 2012 Hi Rohit, Thank you for your reply. Please report this error to the Bundler issue tracker at https://github.com/carlhuda/bundler/issues so that we can fix it. his comment is here Forum List Topic List New Topic Search Register User List Log In Powered by RForum and Captchator.

Successfully installed nokogiri-1.4.1 Successfully installed rack-test-0.5.3 Successfully installed webrat-0.7.0 3 gems installed Installing ri documentation for nokogiri-1.4.1... The problem is two-fold: 1. It installed 0.3.2.2 which works, whereas > "sudo > gem install webrat" installed 0.3.4 which yields the error message "no > such file to load -- webrat/rspec-rails" Hi Fernando.

try 'port install libxslt' or 'yum install libxslt-devel' *** extconf.rb failed *** Could not create Makefile due to some reason, probably lack of necessary libraries and/or headers.

Gemfile source 'https://rubygems.org' gem 'rails', '4.2.4' gem 'pg' gem 'sass-rails', '~> 5.0' gem 'uglifier', '>= 1.3.0' gem 'coffee-rails', '~> 4.1.0' # See https://github.com/rails/execjs#readme for more supported runtimes # gem 'therubyracer', platforms: Reload to refresh your session. no libxslt is missing. Thanks!" Thanks once again for pointing out the correct error.

ActiveRecord::Base.descendants ActiveRecord::Base.descendants.map(&:table_name) johncblandii commented Nov 11, 2015 See above. I've installed an update of g++ through macports, and in the .profile file of my current user there was a value in the PATH var from macports. Issue 2: When I run "bundle install" it gives following message and during nokogiri gem install it asks to create an issue on bundler github issue page: [appsample (master)]$ bundle install weblink Terms Privacy Security Status Help You can't perform that action at this time.

Related 67MySQL Install: ERROR: Failed to build gem native extension5Build a gem with native extension (Gem::Installer::ExtensionBuildError)379Error installing mysql2: Failed to build gem native extension62Ruby gem mysql2 install failing134Nokogiri installation fails -libxml2 There's a quirk in Rails, where if you define the same `has_and_belongs_to_many` relationship multiple times, Rails generates an unnamed subclass of `ActiveRecord::Base`. 2. You signed in with another tab or window. Compute the kangaroo sequence Why does argv include the program name?

Let me know if you need any more information to resolve the issue.