Home > Gem Install > Gem Install Rubyinline Error

Gem Install Rubyinline Error

Biopieces uses third-party programs required for specific Biopieces to work. I recently came across your blog and have been reading along. We recommend upgrading to the latest Safari, Google Chrome, or Firefox. share|improve this answer answered Sep 12 '13 at 21:03 the Tin Man 109k22135206 Thanks Tin Man for your quick reply. navigate here

Try 'gem update --system' to update This indicates that your version of gem is too old. What do I do when two squares are equally valid? Is RubyInline/ZenTest working on making it compatible with the newer versions? Contributors Frogee Precocious Llama We also read: Musings from a PhD candidate Solving problems with graphs YOKOFAKUN Writing a Custom ReadFilter for the GATK, my notebook.

Ruby nor gem were in my path. share|improve this answer answered Sep 18 '13 at 6:36 Jorvis 97378 add a comment| up vote 0 down vote What version of ZenTest are you running? export BP_TMP="/tmp" # Required temporary directory. of the atom whose 1s electron moves nearly at the speed of light?

WRONG GEM! On Ubuntu you need to do this:$ sudo apt-get install ruby-devOn Fedora you would do:$ sudo yum install ruby-develTry it once more and it should work! Join them; it only takes a minute: Sign up Error while installing ZenTest gem up vote 2 down vote favorite [email protected]:~/rails_project/sample_app$ sudo gem install ZenTest [sudo] password for narendra: ERROR: Error Reload to refresh your session.

Try 'gem update --system' to update RubyGems itself". –hewhocomes Sep 12 '13 at 23:57 add a comment| Your Answer draft saved draft discarded Sign up or log in Sign up You can clean out the stale gems after that using gem clean. However, the remaining Biopieces should work just fine. https://github.com/seattlerb/rubyinline/issues/25 Count number of reads in a SAM file above or below...

Nice blog. Problems with Ruby RubyInline Several people have reported problems with Ruby's requirement on RubyInline. Don't forget to add the ruby_install bin directory to your .bashrc file. RubyGems.org is made possible by many sponsors, with development funded by the Ruby trade association, Ruby Together.

Compute the kangaroo sequence Are the words "expression" and "term" interchangeable in programming language theory? Is it plausible for my creature to have similar IQ as humans? Why does this execution plan have Compute Scalars? Join them; it only takes a minute: Sign up My version of RubyGems is too new to install RubyInline/ZenTest up vote 1 down vote favorite I'm trying to install the RubyInline

Each Perl dependency was obtained from CPAN (Perl's package manager). $ sudo cpan > install Inline > install JSON::XS #...and so on until all packages were obtained And finally the installer http://xhpcreations.com/gem-install/gem-install-sproutcore-error.html create_blast_index requires scan_for_matches which is found here. How exactly does mining software work? Bugs & Issues Please report bugs and issues in the issue tracker here.

This page was last updated on Friday, 25-Sep-2015 11:40:42 CDT Installation notes for Biopieces version 2282 Home Page Prerequisites svn Ruby $ sudo apt-get install ruby gem ruby-dev Ruby modules $ You signed out in another tab or window. ZenTest required a different version of rubygem package manager than that which I had installed. his comment is here I also blame the dependencies; I think my problem primarily stemmed from Ubuntu not allowing rubygems to update via the ruby_install.sh script.DeleteReplyAdd commentLoad more...

I hope that when Ruby 2.0 is adopted in the Linux distros life will become easier.ReplyDeleteRepliesFrogeeSeptember 25, 2013 at 5:09 AMThanks for your comment, Martin, and for all of your work Try 'gem update --system' to update RubyGems itself. $ gem update --system ERROR: gem update --system is disabled on Debian, because it will overwrite the content of the rubygems Debian package, Installation of Biopieces on Ubuntu Linux 12.10 - ...

And by the way, YES I have checked to see if I have RubyGems installed the right way :-) Report post Edit Move Delete topic Reply with quote Re: Trouble installing

Animal Shelter in Java more hot questions question feed lang-rb about us tour help blog chat data legal privacy policy work here advertising info mobile contact us feedback Technology Life / Beginnings with Git Advice from a systems software engineer compile errors in Linux VirtualLeaf installation Configuring an IGV Genome Server On the number of markers and the number of individ... more stack exchange communities company blog Stack Exchange Inbox Reputation and Badges sign up log in tour help Tour Start here for a quick overview of the site Help Center Detailed We need your help to keep RubyGems.org running smoothly and free for everyone to use.

Does a survey require an ethical approval? Authors: Ryan Davis Owners: SHA 256 checksum: 205bbc14c02d3d55e1b497241ede832ab87f3d981f92f3bda98b75e8144103e0 ← Previous version Total downloads 1,091,784 For this version 137,666 Gemfile: = Copy to clipboard Copied! Then you probably need to explicitly install an older ZenTest: # gem install ZenTest --no-rdoc --no-ri -v 4.3 Fetching: ZenTest-4.3.0.gem (100%) Successfully installed ZenTest-4.3.0 1 gem installed # gem install image_science weblink Determine the type of an object in Python Call external program from Python and capture its ...

plus you also need the hoe gem$ sudo gem install RubyInline
$ sudo gem install hoeTried running the app and this time I got:ERROR: Can't find header dir for ruby, Exiting...This Here's a combination of what ultimately what worked for me on two of my systems (32-bit Linux Ubuntu 12.10, and 64-bit Linux Ubuntu 12.10) after considerable troubleshooting. When casting a cube spell on a hex grid do you pick a honeycomb for origin or an intersection for origin? What (combination of) licenses is popular for public/shared proprietary software (“Feel free to contribute, but only we can make commercial use”)?

Not the answer you're looking for? Seattle Ruby Brigade member zenspider commented May 1, 2012 No response. Now, to get rid of the warnings (and some of the errors) you need to find out what third-party software is missing. Instantly publish your gems and then install them.

export BP_LOG="$HOME/logs/biopieceslog" # Required log directory. Craic Computing Tech Tips A collection of computer systems and programming tips that you may find useful. Remove everything Ruby from the system first and then download, compile and install Ruby from scratch. If running bp_test suggests that RubyInline is not installed, you should install it using the command: sudo gem install RubyInline Now, if you get the following error: sudo gem install RubyInline

The current is 4.9.3. Is there any job that can't be automated? Conference presenting: stick to paper material? Biopieces uses an external gem (or module) called RubyInline to allow embedded C code that speed certain things up dramatically, so RubyInline is great.