Home > Gem Install > Gem Install Rails Error Lib Not Found

Gem Install Rails Error Lib Not Found

I ran into the same problem until I went to https://help.ubuntu.com/community/RubyOnRails#Get%20Ruby. Installing RDoc documentation for sprockets-2.0.0... Show that a nonabelian group must have at least five distinct elements How to use the binomial theorem to calculate binomials with a negative exponent In the United States is racial, Notify me of new posts via email. this contact form

The source of this solution was the following URL. Serpenstage's answer helped and lead me to find this guide here. Installing ri documentation for tilt-1.3.3... rdoc-data -install will complain about the directory missing: /home/ikon/.rvm/gems/ruby-1.9.2-p290/gems/rdoc-data-2.5.3/data/1.9.2 I overcame with simply creating the missing end directory. http://stackoverflow.com/questions/4129882/rails-3-install-error-file-not-found-lib

Installing RDoc documentation for actionpack-3.0.10... unable to convert "\xF1" from ASCII-8BIT to UTF-8 for README, skipping Installing RDoc documentation for i18n-0.4.2... Installing ri documentation for activemodel-3.1.0...

When casting a cube spell on a hex grid do you pick a honeycomb for origin or an intersection for origin? Hope it works for you! posted June 7, 2011 at 11:23 pm by Justin Marshall Reply Problem Solved..rails installed successfully..thanks for the post posted June 13, 2011 at 8:13 am by arkz Reply Super helpful…was really Thanks!

If it doesn't, try the alternative line given above. Installing RDoc documentation for rack-ssl-1.3.2... Installing RDoc documentation for arel-2.2.1... http://stackoverflow.com/questions/4822052/installing-rails-file-not-found-lib Installing ri documentation for rack-ssl-1.3.2...

This means that the documentation could not be build. Or are there ways to do so post install? Report post Edit Delete Reply with quote Forum List Topic List New Topic Search Register User List Log In Enable email notification | Enable multi-page view Please log in before posting. asked 5 years ago viewed 2298 times active 4 years ago Linked 34 rails 3 install error “File not found: lib” Related 700A concise explanation of nil v.

This is my environment: [email protected]:~$ which ruby /home/feicun/.rvm/rubies/ruby-1.9.2-p290/bin/ruby [email protected]:~$ which gem /home/feicun/.rvm/rubies/ruby-1.9.2-p290/bin/gem [email protected]:~$ which rails /home/feicun/.rvm/gems/ruby-1.9.2-p290/bin/rails [email protected]:~$ gem environment RubyGems Environment: - RUBYGEMS VERSION: 1.8.6 - RUBY VERSION: 1.9.2 (2011-07-09 patchlevel http://theengguy.blogspot.com/2012/09/ruby-on-rails-installation-complains.html I am using the GM of Lion though..ill wait till the beta of xcode 4.1 downloads and try in the morning posted July 3, 2011 at 5:34 am by Evan Kimia Installing ri documentation for polyglot-0.3.2... Installing RDoc documentation for rack-test-0.5.7...

Installing ri documentation for mime-types-1.16... weblink posted September 9, 2011 at 7:31 am by Pratik Mehta Reply i tried that way but still its sayin like this- Installing ri documentation for rails-3.1.0… file ‘lib' not found Installing posted May 9, 2011 at 3:34 pm by Ryan Wong Reply worked brilliantly. posted May 28, 2011 at 2:19 pm by Anand Reply Man, i've had this error it seems like 10 times and this actually worked.

Installing ri documentation for mail-2.2.19... Are leet passwords easily crackable? Join them; it only takes a minute: Sign up Installing Rails: “File not found: lib” [duplicate] up vote 31 down vote favorite 10 This question already has an answer here: rails http://xhpcreations.com/gem-install/gem-install-rails-bus-error.html Contact information - E-Mail: webmaster (at) ruby-forum (dot) com.

Installing RDoc documentation for activemodel-3.0.10... How to draw a path with coordinates defined by f(x) Book of zen kōans How should I deal with a difficult group and a DM that doesn't help? Installing ri documentation for hike-1.2.1...

sudo gem install rails Output: Successfully installed rails-3.0.7 1 gem installed Installing ri documentation for rails-3.0.7...

Installing RDoc documentation for polyglot-0.3.2... Installing RDoc documentation for polyglot-0.3.2... Installing RDoc documentation for arel-1.0.1... Installing RDoc documentation for rack-cache-1.0.3...

Please Help me asap... I came across the same error both times: This is the problematic part: File not found: lib ERROR:  While generating documentation for rails-3.0.7 ... Please log in using one of these methods to post your comment: Email (required) (Address never made public) Name (required) Website You are commenting using your WordPress.com account. (LogOut/Change) You are http://xhpcreations.com/gem-install/gem-install-rails-socket-error.html I suppose there are some problems with permissions.

Do I need to uninstall first and then try re-installing this way, or can I type in the above without uninstalling what I've installed? –Lani1234 Mar 25 '14 at 14:32 add Thanks. Not the answer you're looking for? With modern technology, is it possible to permanently stay in sunlight, without going into space?

Installing ri documentation for actionpack-3.0.10... Installing RDoc documentation for railties-3.0.10... Installing ri documentation for activerecord-3.1.0... Installing RDoc documentation for rails-3.0.7...

EDIT/ #!/usr/bin/ruby -w require 'rubygems' require 'rdoc/data' RDoc::Data.run /EDIT # sudo /var/lib/gems/1.8/gems/rdoc-data-2.5.3/bin/rdoc-data --install # sudo gem rdoc --all --overwrite # sudo mkdir -p /var/lib/gems/1.8/gems/rails-3.0.6/lib # sudo gem rails Good luck! Problem: "gem install rails" would always delete the "lib" folder, even after manually creating it. Installing ri documentation for abstract-1.0.0... posted June 6, 2011 at 12:46 am by greg Reply that's really nice !

But after the creation of four different directory trees I finally got this to work. –stimpy77 May 16 '11 at 2:17 Thank you Simypy77, that solved the problem on mrichman commented Sep 17, 2011 I just got this error using a fresh install of rvm 1.8.3 on OS X Lion with Ruby 1.9.2-head: [email protected]:~# ruby -v ruby 1.9.2p312 (2011-08-11 revision Installing RDoc documentation for abstract-1.0.0...