Home > Gem Install > Gem Install Nmake Error

Gem Install Nmake Error

Owner mynyml commented Sep 25, 2009 Fixed in v0.5.5 Watchr will now automatically use rev on *nix if it's installed, but will not require it as a gem dependency. don't simply overwrite it. We recommend upgrading to the latest Safari, Google Chrome, or Firefox. What happens if one brings more than 10,000 USD with them in the US? navigate here

For the DevKit to work you need a Ruby provided by RubyInstaller (mingw32 based) –Luis Lavena Sep 4 '10 at 1:10 fast-stemmer do not provide binaries for Windows, you Installing RDoc documentation for SystemTimer-1.1.1-x86-mswin32... How to deal with sewage on a map with no water anywhere With the passing of Thai King Bhumibol, are there any customs/etiquette as a traveler I should be aware of? You're mixing mswin32 installation with mingw32 Development Kit. http://stackoverflow.com/questions/3640298/installing-native-ruby-extensions-on-windows-for-jekyll

cl -nologo -I. -Ic:/ruby/lib/ruby/1.8/i386-mswin32 -Ic:/ruby/lib/ruby/1.8/i386-mswin32 -I. -MD -Zi -O2b2xg- -G6 -c - Tcsystem_timer_native.c system_timer_native.c system_timer_native.c(17) : error C2061: syntax error : identifier 'original_mask' system_timer_native.c(17) : error C2059: syntax error : ';' How do I say "best practice" in Esperanto? Now that I have set up the right devkit and set my path vars manually for %DEVKIT%\mingw\bin fast-stemmer compiles a shared object. –Douglas G. NMAKE fatal error stdlib.h no such file Pages 1 Posts [ 1 ] 1 Topic by ajmal017 2012-12-11 11:58:02 ajmal017 Registered: 2010-02-01 Posts: 2 Topic: rails gem installation error..

Jekyll depends on fast-stemmer-1.0.0 and that has to be built as a native extension I found this handy guide on RubyDevKit to install a 'sane' environment on Windows and it works, Reload to refresh your session. Watchr falls back on the non-evented Portable event handler for now. The DevKit is only for the current MinGW port of MRI and YARV, it does not work with the mswin32 port (which, BTW, has been obsolete for quite some time now).

nmake is actually in VC\bin .. –Tigraine Sep 4 '10 at 0:01 You're mixing mswin32 installation with the DevKit which is mingw32. asked 6 years ago viewed 2147 times active 3 years ago Related 0Installing Rake: invalid gem format9How to install the MySQL Ruby Gem on Ubuntu 9.10?6How to configure installed Ruby and Here's the output I got (rails -v=Rails 2.3.5, Windows XP, ruby console) C:\\InstantRails\\rails_apps\\shovell-debug-02>gem install ruby-debug Building native extensions. http://help.rubygems.org/discussions/problems/624-error-installing-cucumber-error-failed-to-build-gem-native-extension You signed in with another tab or window.

Thanks to everyone for pointing that out! I updated the question. date: invalid date '2016-10-16' Why is water evaporated from the ocean not salty? Reload to refresh your session.

I couldn't get "searchlogic" gem to work. If I can't find a true fix by today, I'll update the gem with a workaround. more stack exchange communities company blog Stack Exchange Inbox Reputation and Badges sign up log in tour help Tour Start here for a quick overview of the site Help Center Detailed and it's now time to say that "ruby-installer" + "dev kit" is our choise to build the native gem.

Reload to refresh your session. check over here Update I finally realized that I had not installed Ruby through RubyInstaller.org. ghazel commented Dec 10, 2010 I made a fork which fixes some of this: https://github.com/ghazel/system-timer It's possible to rake package and then install the resulting gem, and it works. more hot questions question feed lang-rb about us tour help blog chat data legal privacy policy work here advertising info mobile contact us feedback Technology Life / Arts Culture / Recreation

It's been a while so I've forgotten the actual steps I took, but I think if you try to install everything separately too you'll have better luck. Is there any way to know when NOT to use my Oyster card? Please grab the newer installer from rubyinstaller.org and the DevKit too Follow the instructions for installation from the wiki page (Development Kit) Hope that helps, cannot put links to the references. his comment is here no creating Makefile nmake 'nmake' is not recognized as an internal or external command, operable program or batch file.

I've already executed VCVARS32.bat which presumably sets up the environment. Are leet passwords easily crackable? Animal Shelter in Java How should I interpret "English is poor" review when I used a language check service before submission?

The devkit is absolutely necessary, but only if I uninstall and then reinstall with the --platform=ruby part does it work (else it won't call the devkit). –Michael Schmitz Jul 29 '13

Results logged to c:/Ruby/lib/ruby/gems/1.8/gems/rdiscount-1.5.5/ext/gem_make.out windows-vista rubygems share|improve this question edited Feb 5 '13 at 20:50 m0nhawk 1,2291120 asked Dec 24 '09 at 11:22 Oscar 49131130 add a comment| 2 Answers 2 more stack exchange communities company blog Stack Exchange Inbox Reputation and Badges sign up log in tour help Tour Start here for a quick overview of the site Help Center Detailed Q:/Rails/Rails/bin/ruby.exe extconf.rbcreating MakefilenmakeMicrosoft (R) Program Maintenance Utility Version 1.50 Copyright (c) Microsoft Corp 1988-94. Home Categories FAQ/Guidelines Terms of Service Privacy Policy Powered by Discourse, best viewed with JavaScript enabled Shop Versioning Reference Articles Premium

Why (in universe) are blade runners called blade runners? no checking for HAVE_RB_IO_T in rubyio.h... Exploded Suffixes Why must the speed of light be the universal speed limit for all the fundamental forces of nature? http://xhpcreations.com/gem-install/gem-install-sproutcore-error.html How can I make LaTeX break the word at the end of line more beautiful?

This could take a while... If you use the mswin32 port, you are more or less on your own. Implementation of a generic List What sense of "hack" is involved in "five hacks for using coffee filters"? Is there any job that can't be automated?

Why would a password requirement prohibit a number in the last character? share|improve this answer edited Oct 15 '10 at 7:59 answered Mar 11 '10 at 12:07 giorgian 3,08611744 My solution was to switch to a Mac =) In a day Animal Shelter in Java more hot questions question feed about us tour help blog chat data legal privacy policy work here advertising info mobile contact us feedback Technology Life / Arts I myself and quite a few others here in the forum seem to have had problems with it.

But it still doesn't work. Maybe I should re-install InstantRails or I don't know. Is there a Korean word for 'Syllable Block'? I've mentioned this issue on the RubyInstaller group before.

This could take a while... I see that @charles' screenshot refers to i386-mingw, so that seems to be the prerequisite then if you cannot use Visual C++ 6.0. Of course reverting changes fixes that.