Home > Gem Install > Gem Install Error Not In Gzip Format

Gem Install Error Not In Gzip Format

up vote 2 down vote I had a similar problem, it worked on my own private laptop, but failed while using a virtual server at work (running Ubuntu 12.10) that used It doesn't matter if it's factory girl or some other gem; if it doesn't connect it's not failing gracefully. Was driving me up the wall for the last 15 mins🙂 Comments RSS Leave a Reply Cancel reply Enter your comment here... Solution: I downloaded the required gems: chunky_png, fssm, compass, sass, haml etc.. navigate here

It's a failed connection. http ://ftp.ruby-lang.org/pub/ruby/1.9/xxx.tar.gz). After a few minutes of troubleshooting I figured out the problem. Files upload. http://stackoverflow.com/questions/13684137/error-while-executing-gem-zlibgzipfileerror-not-in-gzip-format

You signed out in another tab or window. Repeat. First add the correct source: C:\>gem sources -a http://rubygems.org/ http://rubygems.org/ added to sources Then remove the deprecated one: C:\>gem sources -r http://gems.rubyforge.org/ http://gems.rubyforge.org/ removed from sources C:\>gem sources *** CURRENT SOURCES You signed in with another tab or window.

gem install compass --http-proxy http://user:[email protected]:port/ or: SET HTTP_PROXY=http://user:[email protected]:port/ gem install compass More info: gem help install [1] http://yourbugreportneedsmore.info/ -- Luis Lavena Report post Edit Delete Reply with quote Forum List Topic Sent from mobile. … On Jan 28, 2014 9:07 PM, "Sean" ***@***.***> wrote: @drbrain it's not the successful connection I'm worried about; it's the Zlib error when it fails. ;-) Also make sure you are using the latest RubyGems (library) version. $ gem update --system share|improve this answer edited Feb 2 '13 at 1:05 Steven Penny 1 answered Jun 17 '10 This was referenced Dec 3, 2015 Closed Resumable Upload results in broken pipe google/google-api-ruby-client#69 Closed MultiJson::ParseError while using faraday 0.9.1 #449 deanputney added a commit to deanputney/fog-google that referenced this issue

Thanks! Faraday.default_adapter = :httpclient We will investigate this new issue with gzip today, thank you. by default when I instal the gem, the faraday version 0.9.2 is installed. http://stackoverflow.com/questions/36485516/getting-zlibgzipfileerror-not-in-gzip-format It would appear that gem does not check whether the response it receives is actually from the actual rubygems.org server (and it's can't based on the address lookup alone unless you

table.load file, chunk_size: 1 * 1024 * 1024 end end end end quartzmo commented Oct 7, 2015 @gramos74 Thank you. Fetching source index from http://rubygems.org/ Using rake (0.8.7) from system gems [...] Installing twitter (0.9.0) from rubygems repository at http://rubygems.org/ Your bundle is complete! As @jgeewax says, if you have additional details that may help us, please post add them here. Do you have any of the workarounds in place?

Flow Chart with tikzpicture: particular tipes of arrows In Harry Potter book 7, why didn't the Order flee Britain after Harry turned seventeen? WPThemes. %d bloggers like this: Skip to content Ignore Learn more Please note that GitHub no longer supports old versions of Firefox. quartzmo commented Oct 7, 2015 I am looking into the possibility that httpclient does some automatic/transparent decompression that google api client isn't anticipating. Fail publicly.

What is the first movie to show this hard work message at the very end? http://xhpcreations.com/gem-install/gem-install-rubyinline-error.html This conflicts with the HTTPClient's transparent_gzip_decompression setting that was enabled in Faraday 0.9.2. Why does this execution plan have Compute Scalars? blowmage commented Oct 7, 2015 Yeah, that's the key.

Twitter Updates RT @sdesic: Could This Be the Cutest Cat Species in the World? Have you updated to use a 0.9 Gemfile? Files upload. his comment is here I just gone through the source code, and the code expects a .tar.gz in the ftp server (e.g.

asked 6 years ago viewed 7577 times active 3 years ago Linked 1 rubygems.rb:550:in `initialize': not in gzip format (Zlib::GzipFile::Error) Related 1I get this error when installing a gem: “ERROR: While I really do want to fix this, I just didn't understand the actual problem based on your description. Successfully installed mysql2-0.3.11 1 gem installed Installing ri documentation for mysql2-0.3.11...

quartzmo commented Oct 7, 2015 As you can see in the 0.9.2 Faraday adapter for httpclient, there does not appear to be any way to override the new configuration.

Related Posted in Resolving Errors, Ruby | 2 Comments 2 Responses on 25 January 2012 at 2:23 pm | Reply Newbie Sinatra Worked like a charm. This ticket was originally about (afaict) a genuinely corrupted gem, so changing sources didn't make sense to me as a solution. Registration is free and takes only a minute. No registration required!

our gemfile is huge ) And this is the code that I'm using: Faraday.default_adapter = :httpclient require 'gcloud' module GoogleApi module BigQuery class Adapter def initialize(configuration) gcloud = Gcloud.new(configuration.application.project_id, "#{Rails.root}/config/gbq-key.json") @bigquery If Dumbledore is the most powerful wizard (allegedly), why would he work at a glorified boarding school? Bundler member indirect commented Jul 3, 2010 I would be fascinated to know how we can tell that an error from Zlib means you should change your Factory_girl source :\ m3talsmith http://xhpcreations.com/gem-install/gem-install-rdiscount-error.html This conflicts with the HTTPClient's transparent_gzip_decompression setting that was enabled in Faraday 0.9.2.

quartzmo added a commit to quartzmo/google-cloud-ruby that referenced this issue Oct 7, 2015 quartzmo Update docs for Faraday/httpclient gzip change Will you be able to upgrade gcloud-ruby after we release this to see if it resolves your issue? When I try the same command from my workplace I need to use the proxy as mentioned above and that results in an error. Sign up for free to join this conversation on GitHub.

We recommend upgrading to the latest Safari, Google Chrome, or Firefox. more hot questions question feed lang-rb about us tour help blog chat data legal privacy policy work here advertising info mobile contact us feedback Technology Life / Arts Culture / Recreation Something like `gem env` is a good start and increases your chances of getting an answer. When to use "bon appetit"?

gramos74 commented Oct 7, 2015 I changed the adapter to net_http due to: google/google-api-ruby-client#121 seems that the response arrives compressed but it is automatically decompressed before to be passed back to done -----> Gemfile detected, running Bundler Unresolved dependencies detected; Installing... I have this same error, I can rec the VCR but I can't read it. Toggle navigation Little 418 About Little418 mimming.com dinopacks.com ERROR: While executing gem ... (Zlib::GzipFile::Error) not in gzip format Posted by Jen Tong on December 13, 2011 One fine evening I was

First add the correct source: C:\>gem sources -a http://rubygems.org/ http://rubygems.org/ added to sources Then remove the deprecated one: C:\>gem sources -r http://gems.rubyforge.org/ http://gems.rubyforge.org/ removed from sources C:\>gem sources *** CURRENT SOURCES Does a survey require an ethical approval? Already have an account? quartzmo commented Oct 7, 2015 So far, I am not able to reproduce this error.

more hot questions question feed lang-rb about us tour help blog chat data legal privacy policy work here advertising info mobile contact us feedback Technology Life / Arts Culture / Recreation Does not require connection to the ruby website. What (combination of) licenses is popular for public/shared proprietary software (“Feel free to contribute, but only we can make commercial use”)? How?