Home > Gem Install > Error Error Installing Nokogiri Error Failed To Build Gem Native Extension

Error Error Installing Nokogiri Error Failed To Build Gem Native Extension

Contents

You signed out in another tab or window. Check the mkmf.log file for more details. Sorry again for answering your questions with more questions. share|improve this answer edited Dec 24 '11 at 4:34 the Tin Man 109k22135206 answered Jan 31 '10 at 21:03 dh. 211 add a comment| up vote -3 down vote Execute the navigate here

Personal Open source Business Explore Sign up Sign in Pricing Blog Support Search GitHub This repository Watch 1,312 Star 27,239 Fork 6,005 jekyll/jekyll Code Issues 83 Pull requests 38 Projects Results logged to C:/ruby/lib/ruby/gems/1.9.1/gems/hpricot-0.8.1/ext/hpricot_scan/gem_make.out Regards, Report post Edit Delete Reply with quote Re: Can't install hpricot gem Boris Barroso (boriscy) on 2009-04-22 15:32 Boris Barroso wrote: > I can't install hpricot Results logged to /Users/Spladow/.rvm/rubies/ruby-2.0.0-p247/lib/ruby/gems/2.0.0/gems/fast-stemmer-1.0.2/ext/gem_make.out That's it though. Copyright © 1999–2016 Ariejan de Vroom Skip to content Ignore Learn more Please note that GitHub no longer supports old versions of Firefox. http://stackoverflow.com/questions/11605404/installing-hpricot

Error Error Installing Nokogiri Error Failed To Build Gem Native Extension

C:\Ruby19\bin>gem install rmagick Building native extensions. Registration is free and takes only a minute. Already have an account? Please consider an alternative like nokogiri.

Terms Privacy Security Status Help You can't perform that action at this time. Reload to refresh your session. Register here. Did you install Ruby before or after you installed the Command Line Tools?

Is there any job that can't be automated? Install Nokogiri You signed out in another tab or window. I don't know if it's still actual for you Ethan but I've got the same error today trying to install rqr gem with latest ruby(1.9.2dev). https://www.ruby-forum.com/topic/184917 Let me give you the errors which are occurring: C:\My Data\test_remit_fps>bundle Fetching source index for http://rubygems.org/ Using rake (0.8.7) Using abstract (1.0.0) Using activesupport (3.0.5) Using builder (2.1.2) Using i18n (0.5.0)

How should I deal with a difficult group and a DM that doesn't help? ERROR: Error installing nokogiri: ERROR: Failed to build gem native extension. /Users/user_name/.rvm/rubies/ruby-1.9.3-p194/bin/ruby extconf.rb checking for libxml/parser.h... *** extconf.rb failed *** Could not create Makefile due to some reason, probably lack of However, for my own curiosity, does mswin32 means 32-bit windows? Seems pretty clear to me.

Install Nokogiri

Results logged to /Users/Spladow/.rvm/rubies/ruby-2.0.0-p247/lib/ruby/gems/2.0.0/gems/hpricot-0.8.6/ext/fast_xs/gem_make.out Is that helpful at all? Report post Edit Delete Reply with quote Re: Can't install hpricot gem Ruby Student (Guest) on 2009-04-22 21:05 On Wed, Apr 22, 2009 at 2:34 PM, Eric Hodel wrote: >> Error Error Installing Nokogiri Error Failed To Build Gem Native Extension Check the mkmf.log file for more details. more stack exchange communities company blog Stack Exchange Inbox Reputation and Badges sign up log in tour help Tour Start here for a quick overview of the site Help Center Detailed

Word for someone who keeps a group in good shape? I love stack overflow. Skip to content Ignore Learn more Please note that GitHub no longer supports old versions of Firefox. Installing RDoc documentation for nokogiri-1.4.3.1-x86-mingw32...

Terms Privacy Security Status Help You can't perform that action at this time. Make sure you have RubyGems and Ruby installed first, of course. Why doesn't ${@:-1} return the last element of [email protected]? How to limit a xorg installation to a single video driver?

What is your ruby version? You may need configuration options. more stack exchange communities company blog Stack Exchange Inbox Reputation and Badges sign up log in tour help Tour Start here for a quick overview of the site Help Center Detailed

This is my install C:\rubygems-1.3.7>gem install hpricot Building native extensions.

ariejan de vroom blog book recommendations gpg about Install Hpricot on Ubuntu 5 June 2009 It’s quite easy. I do have xcode installed but I'm not sure what else I'm missing. $ gem install hpricot Building native extensions. You may need configuration options.

Provided configuration options: --with-opt-dir --without-opt-dir --with-opt-include --without-opt-include=${opt-dir}/include --with-opt-lib --without-opt-lib=${opt-dir}/lib --with-make-prog --without-make-prog --srcdir=. --curdir --ruby=C:/Ruby19/bin/ruby C:/Ruby19/lib/ruby/1.9.1/mkmf.rb:362:in try_do': The complier failed to generate an executable file. (RuntimeError) You I also tried nokogiri. $ gem install nokogiri Building native extensions.

In my free time I like to repair audio equipment, play the piano and experiment with electronics. when I try to install Jekyll I get an error that reads: Building native extensions. Provided configuration options: --with-opt-dir --without-opt-dir --with-opt-include --without-opt-include=${opt-dir}/include --with-opt-lib --without-opt-lib=${opt-dir}/lib --with-make-prog --without-make-prog --srcdir=. --curdir --ruby=C:/Ruby192/bin/ruby C:/Ruby192/lib/ruby/1.9.1/mkmf.rb:368:in `try_do': The complier failed to generate an executable file. (RuntimeError) You have to install development tools I am using xcode 4.3.6 and installed the command line tools.

Why is water evaporated from the ocean not salty?