Home > Gem Install > Cannot Discover Where Libxml2 Is Located On Your System. Please Make Sure `pkg-config` Is Installed.

Cannot Discover Where Libxml2 Is Located On Your System. Please Make Sure `pkg-config` Is Installed.

Contents

Running 'patch' for libxslt 1.1.28... Running 'patch' for libxml2 2.9.2... OK Activating libxslt 1.1.29 (from /usr/local/var/rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/nokogiri-1.6.8/ports/x86_64-apple-darwin15.5.0/libxslt/1.1.29)... What do I do when two squares are equally valid?

How? Team Nokogiri will keep on doing their best to provide security updates in a timely manner, but if this is a concern for you and want to use the system library no Building nokogiri using packaged libraries. OK Running patch with /Users/mariozig/.rvm/gems/ruby-2.2.1/gems/nokogiri-1.6.6.2/ports/patches/libxslt/0003-Initialize-pseudo-random-number-generator-with-curre.patch...

Cannot Discover Where Libxml2 Is Located On Your System. Please Make Sure `pkg-config` Is Installed.

godie mendoza this work for me, thanks man Vincent Le Gallic Just "Merci beaucoup" 😉 Rob Biedenharn This was just the hint that I needed. sparkrevolutions commented Aug 31, 2016 I tried all of the above to no avail. In it, you'll get: The week's top questions and answers Important community announcements Questions that need answers see an example newsletter By subscribing, you agree to the privacy policy and terms yes ************************************************************************ IMPORTANT NOTICE: Building Nokogiri with a packaged version of libxml2-2.9.2 with the following patches applied: - 0001-Revert-Missing-initialization-for-the-catalog-module.patch - 0002-Fix-missing-entities-after-CVE-2014-3660-fix.patch Team Nokogiri will keep on doing their best to provide

Nokogiri fails to build the native extension. Is there any job that can't be automated? Unsubstantiated Is it illegal for regular US citizens to possess or read documents leaked by Wikileaks? Error Installing Nokogiri Mac OK Running patch with /Users/mariozig/.rvm/gems/ruby-2.2.1/gems/nokogiri-1.6.6.2/ports/patches/libxslt/0009-Fix-certain-patterns-with-predicates.patch...

tishpr commented Oct 9, 2016 Seemed to work for me too, thanks! … On Oct 7, 2016 9:54 PM, "Caio César" ***@***.***> wrote: xcode-select --install worked for me. — You are OK Running patch with /Library/Ruby/Gems/2.0.0/gems/nokogiri-1.6.6.2/ports/patches/libxml2/0001-Revert-Missing-initialization-for-the-catalog-module.patch... share|improve this answer answered Dec 16 '14 at 2:26 kasperite 1,1111610 1 right, you need to install libxml2 :), run brew install libxml2 first then try again. http://stackoverflow.com/questions/24251494/nokogiri-gem-installation-error What should I do now to make sure this nokogiri gem installed successfully?

Building nokogiri using packaged libraries. Mac Install Libxml2 svartalfheim commented Sep 15, 2015 thanks! Check the mkmf.log file for more details. Reload to refresh your session.

Gem Install Nokogiri Ubuntu

share|improve this answer answered Mar 11 at 3:37 Kiryl 314 add a comment| up vote 0 down vote I did all above, but had to do one more thing: Open Xcode http://stackoverflow.com/questions/27496498/failing-to-install-nokogiri-gem checking for gzdopen() in -lz... Cannot Discover Where Libxml2 Is Located On Your System. Please Make Sure `pkg-config` Is Installed. yes checking for xmlRelaxNGSetValidStructuredErrors()... Nokogiri Libxml2 warning: unknown warning option '-Werror=unused-command-line-argument-hard-error-in-future'; did you mean '-Werror=unused-command-line-argument'? [-Wunknown-warning-option] 1 warning generated.

When I run in SSH gem install nokogiri I get this error: Extracting libxml2-2.8.0.tar.gz into tmp/x86_64-unknown-linux-gnu/ports/libxml2/2.8.0... OK Running 'configure' for libxml2 2.9.4... afeld referenced this issue in ffi/ffi Apr 14, 2016 Closed Can't gem install under Alpine #485 ruudud commented Jun 8, 2016 As of nokogiri 1.6.8, the --use-system-libraries work-around is unnecessary. View Here Feel free to reopen this issue if you are still having problems. Nokogiri Libxml2 Is Missing

more stack exchange communities company blog Stack Exchange Inbox Reputation and Badges sign up log in tour help Tour Start here for a quick overview of the site Help Center Detailed Make sure that `gem install nokogiri -v '1.6.5'` succeeds before bundling. Browse other questions tagged ruby-on-rails ruby gem nokogiri or ask your own question. The xcode developer tools installed successfully. –Zulhilmi Zainudin Nov 30 '15 at 10:48 What led everyone to know the error involved xcode? –Jeremy Thomas Oct 6 at 23:08 add

OK Running patch with /Users/mariozig/.rvm/gems/ruby-2.2.1/gems/nokogiri-1.6.6.2/ports/patches/libxslt/0001-Adding-doc-update-related-to-1.1.28.patch... Libxml2 Version 2.6.21 Or Later Is Required! When I try running 'gem install nokogiri', I get this message: extconf failed, exit code 1 Gem files will remain installed in /usr/local/rvm/gems/ruby-2.1.2/gems/nokogiri-1.6.5 for inspection. WPScan member ethicalhack3r commented Oct 20, 2015 Did you try running all of these commands?

How do I say "best practice" in Esperanto?

Reload to refresh your session. Update: Correction, after updating to the latest brew I seem to be good to go. Thank you sooooooooooooo much! :) –Katie H Sep 24 '15 at 14:14 Glad it helped, Katie. (I'll delete this comment as well.) –Cary Swoveland Sep 24 '15 at 23:48 Xmlio.c:1450:52: Error: Use Of Undeclared Identifier 'lzma_ok' In it, you'll get: The week's top questions and answers Important community announcements Questions that need answers see an example newsletter By subscribing, you agree to the privacy policy and terms

Conference presenting: stick to paper material? Join them; it only takes a minute: Sign up nokogiri gem installation error up vote 27 down vote favorite 8 I know there are a lot of questions about this gem Are leet passwords easily crackable? When xcode-select --install gives a cryptic message about some "Software Updater" it means you have to start xcode and click install there.

Error: failed to builed gem native extension0Rails bundle install not working error with nokogiri Hot Network Questions With the passing of Thai King Bhumibol, are there any customs/etiquette as a traveler Sign in to comment Contact GitHub API Training Shop Blog About © 2016 GitHub, Inc.